Skip to main content

Bill Pay System Requirements


The following are the system requirements for a user to access our new digital Bill Pay experiences (June 2015 release). Any browser or device software that does not appear below could result in a poor customer experience.


Online Banking – Windows 10

Recommended Internet Browsers

  • Google Chrome 37 and later
  • Microsoft Internet Explorer 11.x
  • Microsoft Edge
  • Mozilla Firefox 33 and later

Online Banking – Windows 7 and 8.1

Recommended Internet Browsers

  • Google Chrome 37 and later
  • Microsoft Internet Explorer 11.x
  • Mozilla Firefox 33 and later

Online Banking – Windows Vista SP 2 and 3

Recommended Internet Browsers

  • Google Chrome 37 and later
  • Mozilla Firefox 33 and later

Online Banking – Mac OS X 10.6 -10.11

Recommended Internet Browsers

  • Google Chrome 37 and later
  • Safari 9
  • Mozilla Firefox 33 and later

Minimally Compatible Internet Browsers (may look odd in some instances)

  • Safari 6

Mobile/Tablet Banking – Android OS

Recommended Version

  • 4.0.3 and later

Mobile/Tablet Banking – Apple iOS

Recommended Versions

  • iOS 9.x, iOS 10.x

Minimally Compatible Version (may look odd in some instances)

  • iOS 8.x

The following mobile operating systems are not compatible with First Bank’s Mobile Banking:

  • Windows Phone
  • Blackberry
  • Kindle Fire

Note: Cookies and JavaScript must be enabled

  • Other browsers and operating systems may be used; however, some features may not function properly.
  • For maximum security, always use the latest version of a browser. Beta versions of browsers and operating systems are not recommended or supported.
  • Compatibility View for Microsoft Internet Explorer is not supported.
  • If a browser or operating system is no longer supported by the vendor, it is not supported by First Bank Bill Pay